Ubuntu 17.10: Risolvere l’errore “ERROR: libusb-0.1 is required” durante l’installazione del driver Brother brscan4

Ubuntu 17.10: Risolvere l’errore “ERROR: libusb-0.1 is required” durante l’installazione del driver Brother brscan4

In questi giorni sto provando la versione in sviluppo di Ubuntu 17.10, nella fattispecie sto provando Ubuntu MATE. Nel mio consueto giro post installazione, durante l’installazione della mia stampante multifunzione Brother DCP 1512, mi sono imbattuto in un errore relativo all’installazione della parte scanner (il pacchetto brscan4)

L’errore è

ERROR: libusb-0.1 is required

Questo errore comportava la mancata installazione dei driver relativi allo scanner.

Per poter risolvere il problema vi basterà installare il pacchetto libusb-dev che, una volta installato, si poterà dietro il pacchetto che ci interessa.

Da terminale ci basterà dare:

sudo apt install libusb-dev

Una volta fatto procediamo nuovamente con l’installazione del pacchetto brscan4 che questa volta si installerà con successo consentendoci di far funzionare lo scanner.